aboutsummaryrefslogtreecommitdiffstats
path: root/testing/platformio-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/platformio-core/APKBUILD')
-rw-r--r--testing/platformio-core/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/testing/platformio-core/APKBUILD b/testing/platformio-core/APKBUILD
index 691ca37b83c..aeda99edcc9 100644
--- a/testing/platformio-core/APKBUILD
+++ b/testing/platformio-core/APKBUILD
@@ -5,11 +5,11 @@ pkgver=3.2.1
pkgrel=0
pkgdesc="An open source ecosystem for IoT development"
url="http://platformio.org"
-arch="all"
+arch="noarch"
license="Apache-2.0"
-depends="python py-bottle py-click5 py-lockfile py-serial
- py-requests py-colorama py-semanticversion"
-makedepends="python-dev py-setuptools"
+depends="py3-bottle py3-click5 py3-colorama py3-lockfile py3-requests
+ py3-semanticversion py3-serial"
+makedepends="py3-setuptools"
install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/platformio/platformio-core/archive/v$pkgver.tar.gz"
@@ -17,12 +17,14 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- python setup.py build || return 1
+ python3 setup.py build || return 1
+ cd "$builddir"/scripts
+ 2to3 -w *.py
}
package() {
cd "$builddir"
- python setup.py install --prefix=/usr \
+ python3 setup.py install --prefix=/usr \
--root="$pkgdir" || return 1
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/