aboutsummaryrefslogtreecommitdiffstats
path: root/testing/poetry/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/poetry/APKBUILD')
-rw-r--r--testing/poetry/APKBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/testing/poetry/APKBUILD b/testing/poetry/APKBUILD
deleted file mode 100644
index 4af8139d9d1..00000000000
--- a/testing/poetry/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Contributor: Michał Polański <michal@polanski.me>
-# Maintainer: Michał Polański <michal@polanski.me>
-pkgname=poetry
-pkgver=1.1.12
-pkgrel=1
-pkgdesc="Python3 dependency management and packaging system"
-url="https://python-poetry.org"
-license="MIT"
-arch="noarch !ppc64le !mips64" # limited by py3-keyring
-options="!check" # TODO: add tests
-depends="
- python3
- py3-poetry-core
- py3-cleo
- py3-clikit
- py3-crashtest
- py3-requests
- py3-cachy
- py3-requests-toolbelt
- py3-cachecontrol
- py3-pkginfo
- py3-html5lib
- py3-shellingham
- py3-tomlkit
- py3-pexpect
- py3-packaging
- py3-virtualenv
- py3-keyring
- "
-makedepends="pyproject2setuppy"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sdispater/poetry/archive/$pkgver.tar.gz"
-
-build() {
- python3 -m pyproject2setuppy.main build
-}
-
-package() {
- python3 -m pyproject2setuppy.main install \
- --prefix=/usr --root="$pkgdir" --skip-build
-
- # remove conflicts with files owned by py3-poetry-core (direct dependency of poetry)
- # see: https://github.com/python-poetry/poetry/issues/2800
- local sitedir=$(python3 -c "import site; print(site.getsitepackages()[0])")
- rm "$pkgdir/$sitedir"/poetry/__init__.py \
- "$pkgdir/$sitedir"/poetry/__pycache__/__init__.cpython-*.pyc
-}
-
-sha512sums="
-2a779ffbf2438624116312ad331f3dab30f18c966c5d51886a135f94358686d307ccf4a416cad6f2619694560ebefa7114a0921f787086bfb46de41db04d20b1 poetry-1.1.12.tar.gz
-"