aboutsummaryrefslogtreecommitdiffstats
path: root/testing/poke/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/poke/APKBUILD')
-rw-r--r--testing/poke/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/poke/APKBUILD b/testing/poke/APKBUILD
new file mode 100644
index 00000000000..26a6b7fe189
--- /dev/null
+++ b/testing/poke/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=poke
+pkgver=3.3
+pkgrel=0
+pkgdesc="extensible editor for binary data"
+url="https://www.jemarch.net/poke.html"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="automake autoconf help2man gc-dev readline-dev gettext-dev json-c-dev dejagnu-dev"
+checkdepends="dejagnu"
+subpackages="$pkgname-doc"
+source="https://ftp.gnu.org/gnu/poke/poke-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make -k check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+b00dca38d27bddee6ea131d45988aaead1d11d29b757c048f3b2be8013575cedc591844d4d99870f90964fd4f517d500cbb42aae5aff57e9fe07aac8273aa236 poke-3.3.tar.gz
+"