aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ponyc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ponyc/APKBUILD')
-rw-r--r--testing/ponyc/APKBUILD76
1 files changed, 0 insertions, 76 deletions
diff --git a/testing/ponyc/APKBUILD b/testing/ponyc/APKBUILD
deleted file mode 100644
index 4185270d879..00000000000
--- a/testing/ponyc/APKBUILD
+++ /dev/null
@@ -1,76 +0,0 @@
-# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
-pkgname=ponyc
-pkgver=0.30.0
-pkgrel=0
-pkgdesc="An open-source, actor-model, capabilities-secure, high performance programming language"
-url="https://www.ponylang.org"
-arch="all !s390x !ppc64le"
-license="BSD-2-Clause"
-_llvmver=6
-depends="binutils-gold"
-checkdepends="openssl-dev pcre2-dev"
-# Ponyc _is_ compatible with LLVM7, but LLVM7 is pretty buggy on musl.
-makedepends="libexecinfo-dev llvm${_llvmver}-dev ncurses-dev paxmark
- zlib-dev linux-headers"
-options="!check"
-subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ponylang/$pkgname/archive/$pkgver.tar.gz
- more-portable-ln.patch
- makefile-remove-march-mtune.patch"
-
-export LLVM_CONFIG=/usr/lib/llvm${_llvmver}/bin/llvm-config
-# Required to not crash gold: https://sourceware.org/bugzilla/show_bug.cgi?id=23856
-export CFLAGS="$CFLAGS -fPIE"
-
-build() {
- make \
- config=release \
- default_pic=true \
- verbose=true
-
- paxmark m build/release/ponyc \
- build/release/libponyc.tests
-
- mkdir docs
- build/release/ponyc packages/stdlib -rexpr -g -o docs
-}
-
-check() {
- make test
-}
-
-package() {
- make \
- config=release \
- default_pic=true \
- ponydir="$pkgdir"/usr/lib/pony/$pkgver \
- prefix="$pkgdir"/usr \
- install
-
- # links to $pkgdir
- ln -sf /usr/lib/pony/$pkgver/lib/native/libponyrt.a "$pkgdir"/usr/lib/libponyrt.a
- ln -sf /usr/lib/pony/$pkgver/lib/native/libponyrt-pic.a "$pkgdir"/usr/lib/libponyrt-pic.a
- ln -sf /usr/lib/pony/$pkgver/lib/native/libponyc.a "$pkgdir"/usr/lib/libponyc.a
- ln -sf /usr/lib/pony/$pkgver/bin/ponyc "$pkgdir"/usr/bin/ponyc
-
- # We install these manually in dev()
- rm -r "$pkgdir"/usr/include/
-
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname
- cp -r docs/stdlib-docs/docs "$pkgdir"/usr/share/doc/$pkgname/stdlib
-}
-
-# Note: libponyrt*.a and libponyc.a are needed in runtime.
-dev() {
- pkgdesc="$pkgdesc (development files)"
- depends="$pkgname=$pkgver-r$pkgrel"
-
- mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/lib/pony/$pkgver/include "$subpkgdir"/usr
-}
-
-sha512sums="fbf59a687e85d02ddcc5c8f56911005e2aaa5721c97f17f1cb5209f7a8de8e19182dce6aa2d6a9373d03e4cd7161ee595b3229b3b2443dbd647d59ce4e6cc435 ponyc-0.30.0.tar.gz
-38aa40f6000dcb823be7b542cdad8d04b6ac4cd0a4fff1a472520a7cb71631fb34e5bee74914fe559674594dd901aede91390809e143dd96c5d68a16f8ac196c more-portable-ln.patch
-c78156bc68332705c41e7f4f8ff65bb77a778d8ee1685e9376473041c9c0b815e96ebc4cfd68b03c5c5c9d53cff8e6c0deba0fc19a9bcb29b7f91caaa15a0803 makefile-remove-march-mtune.patch"