aboutsummaryrefslogtreecommitdiffstats
path: root/testing/postgresql-timescaledb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/postgresql-timescaledb/APKBUILD')
-rw-r--r--testing/postgresql-timescaledb/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/postgresql-timescaledb/APKBUILD b/testing/postgresql-timescaledb/APKBUILD
new file mode 100644
index 00000000000..57cfd3a7303
--- /dev/null
+++ b/testing/postgresql-timescaledb/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: wener <wenermail@gmail.com>
+# Maintainer: wener <wenermail@gmail.com>
+pkgname=postgresql-timescaledb
+_projname=timescaledb
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="An open-source database designed to make SQL scalable for time-series data"
+url="https://github.com/timescale/timescaledb"
+arch="all"
+license="Apache-2.0"
+provides="timescaledb=$pkgver-r$pkgrel" # for backward compatibility
+makedepends="postgresql-dev cmake bash"
+source="https://github.com/timescale/timescaledb/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_projname-$pkgver"
+
+build() {
+ # REGRESS_CHECKS=OFF - disable regress test
+ # regress need https://github.com/timescale/timescaledb/blob/master/test/pg_isolation_regress.sh
+ # which need to compile pg - https://github.com/timescale/timescaledb/issues/1655#issuecomment-578683986
+ BUILD_FORCE_REMOVE=true ./bootstrap -DREGRESS_CHECKS=OFF
+ make -C build USE-PGXS=1
+}
+
+check() {
+ make -C build test
+}
+
+package() {
+ make -C build USE_PGXS=1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="53fddb9fe4c4ab51ebc020e90eea5b032b41259d3bd45e8a03a86451acd7f8864b5a6ecba1b82b7c78e230f62cfddf1da75ff27e6629ad5fe8178839ac411ce4 postgresql-timescaledb-2.1.0.tar.gz"