aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ptex/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ptex/APKBUILD')
-rw-r--r--testing/ptex/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/ptex/APKBUILD b/testing/ptex/APKBUILD
deleted file mode 100644
index a7c1954b922..00000000000
--- a/testing/ptex/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Leon Marz <main@lmarz.org>
-# Maintainer: Leon Marz <main@lmarz.org>
-pkgname=ptex
-pkgver=2.4.1
-pkgrel=0
-pkgdesc="texture mapping system by Walt Disney Animation Studios"
-url="https://ptex.us/"
-arch="all !s390x !mips64" # ptex doesn't like big endian
-license="BSD-3-Clause"
-makedepends="cmake doxygen graphviz zlib-dev"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/wdas/ptex/archive/v$pkgver.tar.gz"
-
-build() {
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
- -DPTEX_VER=$pkgver
- cmake --build build
-}
-
-check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-ccf6b51650286c39a9f25c105a2303ab5dfc9f9d9d02cd98c6ffc976ed17f39d97968f2b9c68e269fd59db905768c36eab6a03e2014c7b2cbb83cb8a530bd35c ptex-2.4.1.tar.gz
-"