aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ptex/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ptex/APKBUILD')
-rw-r--r--testing/ptex/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/ptex/APKBUILD b/testing/ptex/APKBUILD
deleted file mode 100644
index dbca79a94cd..00000000000
--- a/testing/ptex/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Leon Marz <main@lmarz.org>
-# Maintainer: Leon Marz <main@lmarz.org>
-pkgname=ptex
-pkgver=2.4.0
-pkgrel=0
-pkgdesc="texture mapping system by Walt Disney Animation Studios"
-url="https://ptex.us"
-arch="all !s390x !mips64" # ptex doesn't like big endian
-license="BSD-3-Clause"
-makedepends="cmake doxygen graphviz zlib-dev"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/wdas/ptex/archive/v$pkgver.tar.gz"
-
-build() {
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
- -DPTEX_VER=$pkgver
- cmake --build build
-}
-
-check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-02879a7d8c57206d23ba6cacc460e681a4fc03e8939a42ac47e67dcfe0c2fbba247453ea1b6d6a4b8cef389a0830906b018afff6ec8691d01b28ac23fc748c5b ptex-2.4.0.tar.gz
-"