aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pulseaudio-modules-bt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pulseaudio-modules-bt/APKBUILD')
-rw-r--r--testing/pulseaudio-modules-bt/APKBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/testing/pulseaudio-modules-bt/APKBUILD b/testing/pulseaudio-modules-bt/APKBUILD
deleted file mode 100644
index 238d26a38d3..00000000000
--- a/testing/pulseaudio-modules-bt/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-# This APKBUILD is looking for a new maintainer
-pkgname=pulseaudio-modules-bt
-pkgver=1.4
-pkgrel=2
-# TODO: Package libldacBT, so that this also provides LDAC support
-pkgdesc="Pulseaudio bluetooth with support for APTX, APTX-HD, AAC"
-url="https://github.com/EHfive/pulseaudio-modules-bt"
-arch="all"
-license="GPL-3.0-only"
-_pulseaudio_ver=15.0
-makedepends="
- bluez-dev
- cmake
- dbus-dev
- ffmpeg-dev
- libtool
- pulseaudio-dev
- sbc-dev
- fdk-aac-dev
- "
-source="
- $pkgname.tar.gz::https://github.com/EHfive/pulseaudio-modules-bt/archive/v$pkgver.tar.gz
- https://freedesktop.org/software/pulseaudio/releases/pulseaudio-$_pulseaudio_ver.tar.xz
- "
-provides="pulseaudio-bluez=$_pulseaudio_ver"
-options="!check" # no unit tests provided
-
-prepare() {
- default_prepare
-
- # As this provides a pulseaudio module, the internal pulseaudio API is used.
- # This API is not provided by pulseaudio-dev, so we make the headers
- # available directly from source.
- rm -rf pa
- ln -sf ../pulseaudio-$_pulseaudio_ver pa
-}
-
-build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-
-sha512sums="
-390b6ad0931b464a546c6624bec38cc5b6da7084e4defe2045f4164b0c910a9dd6d4327466eb0e53fcfbc78c995cf2e3634a75b67ee2a14f38ed18e31b5d2bce pulseaudio-modules-bt.tar.gz
-352ef20384c76c631c0faa73b08e2318902a433712e0c086a5ac7a0ae58873c8d4be8f35879bdec71a93b19ae8e2ba073cacac4d56215bcf58375a0cd9d88833 pulseaudio-15.0.tar.xz
-"