aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pulseaudio-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pulseaudio-qt/APKBUILD')
-rw-r--r--testing/pulseaudio-qt/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/pulseaudio-qt/APKBUILD b/testing/pulseaudio-qt/APKBUILD
new file mode 100644
index 00000000000..ca7501815e8
--- /dev/null
+++ b/testing/pulseaudio-qt/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=pulseaudio-qt
+pkgver=1.1.0
+pkgrel=0
+arch="all"
+url="https://cgit.kde.org/pulseaudio-qt.git/"
+pkgdesc="Pulseaudio bindings for Qt"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends_dev="qt5-qtbase-dev pulseaudio-dev glib-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
+checkdepends="qt5-qtdeclarative-dev"
+source="https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="8d143a6c3dd0f1fd824fa1f0233435243cf551739e5ddf2579a86bc1c25c479f42d56a5cb7ef886513118ef5f37106062e49c0955b4ab356682c310d391ff11c pulseaudio-qt-1.1.0.tar.xz"