aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pwauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pwauth/APKBUILD')
-rw-r--r--testing/pwauth/APKBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/testing/pwauth/APKBUILD b/testing/pwauth/APKBUILD
index 638498045bf..3789422566a 100644
--- a/testing/pwauth/APKBUILD
+++ b/testing/pwauth/APKBUILD
@@ -2,35 +2,28 @@
# Maintainer: Nathan Rennie-Waldock <nathan.renniewaldock@gmail.com>
pkgname=pwauth
pkgver=2.3.11
-pkgrel=0
+pkgrel=1
pkgdesc="Authenticator for mod_authnz_external and Apache"
-url="https://code.google.com/p/pwauth/"
+url="https://github.com/phokz/pwauth"
arch="all"
license="BSD-3-Clause"
-depends=""
-makedepends=""
-install=""
subpackages="$pkgname-doc"
-source="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/pwauth/$pkgname-$pkgver.tar.gz
+source="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/pwauth/pwauth-$pkgver.tar.gz
10-config.patch
- 20-fix-warnings.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+ 20-fix-warnings.patch
+ "
options="suid"
build() {
- cd "$builddir"
- make || return 1
-
+ make
}
package() {
- cd "$builddir"
- install -Dm4755 pwauth "$pkgdir/usr/sbin/pwauth" || return 1
+ install -Dm4755 pwauth "$pkgdir/usr/sbin/pwauth"
- local f
- for f in unixgroup INSTALL FORM_AUTH; do
+ local f; for f in unixgroup INSTALL FORM_AUTH; do
install -Dm644 "$f" \
- "$pkgdir/usr/share/doc/$pkgname/$f" || return 1
+ "$pkgdir/usr/share/doc/$pkgname/$f"
done
}