aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-fedmsg
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-fedmsg')
-rw-r--r--testing/py-fedmsg/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/py-fedmsg/APKBUILD b/testing/py-fedmsg/APKBUILD
new file mode 100644
index 00000000000..381f0e05e69
--- /dev/null
+++ b/testing/py-fedmsg/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-fedmsg
+_pkgname=fedmsg
+pkgver=0.16.2
+pkgrel=0
+pkgdesc="Utilities used around Fedora Infrastructure to send and receive messages"
+url="https://fedmsg.readthedocs.org/"
+arch="noarch"
+license="LGPLv2"
+depends="python"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://pypi.python.org/packages/source/f/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="43fc8257724252b38b34608b0c9a2218 fedmsg-0.16.2.tar.gz"
+sha256sums="e5b20647b65b48af544bbc0fe338e00a16de572c191a0019c8c511daf200c596 fedmsg-0.16.2.tar.gz"
+sha512sums="88a7350165088ad105a697dc28d685e453d277a06615e61cc9733832cfb678b6f943fa0439b52a1107b23258751c88a39e7332dcc285eb5ae930ce3d582c8eb6 fedmsg-0.16.2.tar.gz"