aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-prompt_toolkit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-prompt_toolkit/APKBUILD')
-rw-r--r--testing/py-prompt_toolkit/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-prompt_toolkit/APKBUILD b/testing/py-prompt_toolkit/APKBUILD
new file mode 100644
index 00000000000..5f2c8e17ba1
--- /dev/null
+++ b/testing/py-prompt_toolkit/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py-prompt_toolkit
+_pkgname=prompt_toolkit
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="Library for building powerful interactive command lines in Python"
+url="https://pypi.python.org/pypi/prompt_toolkit"
+arch="noarch"
+license="BSD"
+depends="python py-six py-wcwidth"
+makedepends="python-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6c4133d099603f496c761491043bf0ef py-prompt_toolkit-1.0.3.tar.gz"
+sha256sums="805e026f0cbad27467e93f9dd3e3777718d401a62788c1e84ca038e967ad8ba2 py-prompt_toolkit-1.0.3.tar.gz"
+sha512sums="c7615c42c7923bb2cefb8db536405976975d25a7df110698e9664f205d3428b6bbf6ca2aba8b0d85957296fcac0bf65752d025cabdb25c80f149f9b92c0c445d py-prompt_toolkit-1.0.3.tar.gz"