aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pymysql/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-pymysql/APKBUILD')
-rw-r--r--testing/py-pymysql/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/testing/py-pymysql/APKBUILD b/testing/py-pymysql/APKBUILD
deleted file mode 100644
index ec7d9413716..00000000000
--- a/testing/py-pymysql/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Thomas Boerger <thomas@webhippie.de>
-# Maintainer: Thomas Boerger <thomas@webhippie.de>
-pkgname=py-pymysql
-_pkgname=PyMySQL
-pkgver=0.9.2
-pkgrel=1
-pkgdesc="Pure Python MySQL Client"
-url="https://pypi.python.org/pypi/PyMySQL"
-arch="noarch"
-license="MIT"
-options="!check" #require mysql for tests
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="4918802808fb12417db682831290adfa5a785ca34da5674b7a8ccc7c942a1de424c3085282912df326131e978daf771d71c6b33aeb3cb2590c70b5ff6e557b07 py-pymysql-0.9.2.tar.gz"