aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-telegram-bot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-telegram-bot/APKBUILD')
-rw-r--r--testing/py-telegram-bot/APKBUILD43
1 files changed, 31 insertions, 12 deletions
diff --git a/testing/py-telegram-bot/APKBUILD b/testing/py-telegram-bot/APKBUILD
index 3f43247897e..937f053e8bb 100644
--- a/testing/py-telegram-bot/APKBUILD
+++ b/testing/py-telegram-bot/APKBUILD
@@ -2,30 +2,49 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-telegram-bot
_pkgname=${pkgname/py/python}
-pkgver=5.1
+pkgver=8.0.0
pkgrel=0
pkgdesc="A Python wrapper around the Telegram Bot API"
url="https://github.com/python-telegram-bot/python-telegram-bot"
arch="noarch"
-license="LGPLv3"
-depends="py-futures"
+license="LGPL3+"
+depends="py-futures py-certifi"
depends_dev=""
-makedepends="$depends_dev py-setuptools"
+makedepends="python2-dev python3-dev py2-setuptools"
install=""
-subpackages=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$pkgname-$pkgver.zip::https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.zip"
-_builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ mkdir -p "$pkgdir"
}
-md5sums="a6a4bfe32b628a9c757288487521ac20 py-telegram-bot-5.1.zip"
-sha256sums="ac5040ca277ace47d9f21c00cbc87eb557b535760f940d5d0052938edb705969 py-telegram-bot-5.1.zip"
-sha512sums="5e9bef2018e974e5740e9d381f41de4ab6eecfc0cebfc7f0c8c6e69423d7b41117431b36af772d8e91c6d6e1db9811e9bd8970aaba15d83b792590bef7f64d0c py-telegram-bot-5.1.zip"
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="179b0a84bbee2b55acf45cbe4225723369ff025d4474cb8aa922f6d94128cb96c2c630108213a824877b1580461de7f748476829e4274341b6ee1c670d2ae6c2 py-telegram-bot-8.0.0.zip"