aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-testtools
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-testtools')
-rw-r--r--testing/py-testtools/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/py-testtools/APKBUILD b/testing/py-testtools/APKBUILD
new file mode 100644
index 00000000000..8186406d5b7
--- /dev/null
+++ b/testing/py-testtools/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-testtools
+_pkgname="testtools"
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="Extensions to the Python standard library unit testing framework"
+url="https://pypi.python.org/pypi/testtools"
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}" ## remove if there are no common Python dependencies
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}" ## remove if there are no common Python dependencies
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="f5ba08971975aa1ccf923c4c997ca7b093d00615131f440a9a5aad96d63be5b9e72f3364f3185d523fce9b5a7055bd52f767b54f7f9f17a102c4166efec189c5 testtools-2.2.0.tar.gz"