aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-vine/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-vine/APKBUILD')
-rw-r--r--testing/py-vine/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/testing/py-vine/APKBUILD b/testing/py-vine/APKBUILD
deleted file mode 100644
index 2c2c77a567d..00000000000
--- a/testing/py-vine/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer:
-pkgname=py-vine
-pkgver=1.1.4
-pkgrel=1
-pkgdesc="futures and promises implementation for python"
-url="https://pypi.python.org/pypi/vine/"
-arch="noarch"
-license="BSD"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-vine:py2 py3-vine:py3"
-source="https://files.pythonhosted.org/packages/source/v/vine/vine-$pkgver.tar.gz"
-builddir="$srcdir/vine-$pkgver"
-
-build() {
- cd "$_builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ${python#python}"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-py2() {
- cd "$builddir"
- _py python2
-}
-
-py3() {
- cd "$builddir"
- _py python3
-}
-
-sha512sums="b85438cd30b3cb6c642380b3da120783cf2d4306366e04a141061d40cf6b8ce5b52ca15562b71f28392ad376c1f160b39162fa7933665b5c21179b0994347460 vine-1.1.4.tar.gz"