aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py2-backports_functools_lru_cache
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py2-backports_functools_lru_cache')
-rw-r--r--testing/py2-backports_functools_lru_cache/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py2-backports_functools_lru_cache/APKBUILD b/testing/py2-backports_functools_lru_cache/APKBUILD
new file mode 100644
index 00000000000..79677c9a5b9
--- /dev/null
+++ b/testing/py2-backports_functools_lru_cache/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py2-backports_functools_lru_cache
+_pkgname=backports.functools_lru_cache
+pkgver=1.5
+pkgrel=0
+pkgdesc="Backport of functools.lru_cache from Python 3.3 as published at ActiveState"
+url="https://pypi.org/project/backports.functools_lru_cache/"
+arch="noarch"
+license="BSD-2-Clause"
+makedepends="python2-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+}
+
+sha512sums="083a69beb050a6de0f838231ceae05cd1825f42310b2cd4f0e53f7ca043af4c699ad7042c32831ee365bb6b374d33189136e45689c77815b99773d145f0ef4f1 backports.functools_lru_cache-1.5.tar.gz"