aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py2-unittest2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py2-unittest2/APKBUILD')
-rw-r--r--testing/py2-unittest2/APKBUILD31
1 files changed, 0 insertions, 31 deletions
diff --git a/testing/py2-unittest2/APKBUILD b/testing/py2-unittest2/APKBUILD
deleted file mode 100644
index a0c55853ad4..00000000000
--- a/testing/py2-unittest2/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=py2-unittest2
-_pkgname=${pkgname#py2-*}
-pkgver=1.1.0
-pkgrel=0
-pkgdesc="Backport of the Python3 enhanced unittest testing framework"
-url="https://pypi.python.org/pypi/unittest2"
-arch="noarch"
-license="PSF"
-depends="py2-six py2-argparse py2-traceback2 py2-linecache2"
-makedepends="python2-dev py-setuptools"
-source="$pkgname-$pkgver.tar.gz::http://http.debian.net/debian/pool/main/u/$_pkgname/${_pkgname}_${pkgver}.orig.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
-}
-
-check() {
- cd "$builddir"
- python2 -m unittest2 discover
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="3fba15728905f437767416ab4fd3573d3fb2319486ef84c52a9fa930ea84aa1f2ae29d6f58993e3509083625790e17b1ef8d9ac5de0e166c254897a3e7a202fa py2-unittest2-1.1.0.tar.gz"