aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-aiohttp-jinja2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-aiohttp-jinja2/APKBUILD')
-rw-r--r--testing/py3-aiohttp-jinja2/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/testing/py3-aiohttp-jinja2/APKBUILD b/testing/py3-aiohttp-jinja2/APKBUILD
index 855fe7d382a..00d22a6c7e8 100644
--- a/testing/py3-aiohttp-jinja2/APKBUILD
+++ b/testing/py3-aiohttp-jinja2/APKBUILD
@@ -2,24 +2,30 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-aiohttp-jinja2
_pkgname=aiohttp_jinja2
-pkgver=1.4.2
-pkgrel=1
+pkgver=1.6
+pkgrel=2
pkgdesc="Jinja2 template renderer for aiohttp"
options="!check" # Requires unpackaged pytest-aiohttp
url="https://github.com/aio-libs/aiohttp-jinja2"
arch="noarch"
license="Apache-2.0"
depends="py3-aiohttp py3-jinja2"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/aio-libs/aiohttp-jinja2/archive/v$pkgver.tar.gz"
builddir="$srcdir"/aiohttp-jinja2-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="09356f5f010504b5d1449196006162e6daeeeee8671e261d2b4fa66d5ba0ede386a2782fa84cd46647f4f6077bf3539217546850543ebbdb0bd4b70a8c698d17 aiohttp_jinja2-1.4.2.tar.gz"
+sha512sums="
+a434443580b050ac849f80ec3fc1815bce7b682febadb827e473e6b8b88d79017335cf2cd93bfc37d8ab79552afedaf5a67cb961341407d768bce0c15fa20b3c aiohttp_jinja2-1.6.tar.gz
+"