aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-allfiles/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-allfiles/APKBUILD')
-rw-r--r--testing/py3-allfiles/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/testing/py3-allfiles/APKBUILD b/testing/py3-allfiles/APKBUILD
index 1eb54045087..577d15c79b0 100644
--- a/testing/py3-allfiles/APKBUILD
+++ b/testing/py3-allfiles/APKBUILD
@@ -3,26 +3,28 @@
pkgname=py3-allfiles
_pkgname=allfiles
pkgver=1.0
-pkgrel=0
+pkgrel=7
pkgdesc="Iterator for matching files in directory trees"
-url="https://pypi.python.org/pypi/allfiles"
+url="https://pypi.org/project/allfiles"
arch="noarch"
license="MIT"
-replaces="py-allfiles" # for backwards compatibility
+replaces="py-allfiles" # for backwards compatibility
provides="py-allfiles=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="698f1131950eba7cc12af727e2c27c5018c1d81ab1cca7f94f308061220003b5b412ef4720ba1bbebc50e7fee4f5549c43868d2cfe81e99df1f78e6bf7c38d0f allfiles-1.0.zip"