aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-amqp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-amqp/APKBUILD')
-rw-r--r--testing/py3-amqp/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/testing/py3-amqp/APKBUILD b/testing/py3-amqp/APKBUILD
deleted file mode 100644
index 51b769e32f6..00000000000
--- a/testing/py3-amqp/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py3-amqp
-_pyname=amqp
-pkgver=2.5.2
-pkgrel=0
-pkgdesc="an AMQP implementation"
-url="https://pypi.python.org/pypi/amqp/"
-arch="noarch"
-license="BSD-3-Clause"
-makedepends="py3-setuptools"
-checkdepends="py3-vine py3-case py3-nose py2py3-mock"
-_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
-builddir=$srcdir/$_pyname-$pkgver
-# requires a running rabbitmq sever, which is more complicated than it sounds
-options="!check"
-
-replaces="py-amqp" # Backwards compatibility
-provides="py-amqp=$pkgver-r$pkgrel" # Backwards compatibility
-
-prepare() {
- sed -i requirements/test.txt -e 's/pytest-sugar.*//g'
-}
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="c540ce39c06bb947e55b4afc56567d5fc5a82b65a2f7e2cc1f769f96da74f788d14e1e9c02852a259a4980c36a4524f07166686c0357f96219fd9f8612a6159a amqp-2.5.2.tar.gz"