aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ansi2html/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-ansi2html/APKBUILD')
-rw-r--r--testing/py3-ansi2html/APKBUILD41
1 files changed, 26 insertions, 15 deletions
diff --git a/testing/py3-ansi2html/APKBUILD b/testing/py3-ansi2html/APKBUILD
index 5993bfee045..81ce7eb5359 100644
--- a/testing/py3-ansi2html/APKBUILD
+++ b/testing/py3-ansi2html/APKBUILD
@@ -2,35 +2,46 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-ansi2html
_pkgname=ansi2html
-pkgver=1.6.0
-pkgrel=2
+pkgver=1.9.1
+pkgrel=1
pkgdesc="Convert text with ANSI color codes to HTML"
-url="https://github.com/ralphbean/ansi2html"
+url="https://github.com/pycontribs/ansi2html"
arch="noarch"
license="LGPL-3.0-or-later"
-depends="python3 py3-six py3-setuptools"
-makedepends="python3-dev"
+depends="python3"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-ansi2html" # for backwards compatibility
provides="py-ansi2html=$pkgver-r$pkgrel" # for backwards compatibility
-prepare() {
- default_prepare
+export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
- sed -e '/setuptools_scm/d' \
- -e "s/use_scm_version=.*/version='$pkgver',/" \
- -i setup.py
- sed -e '/setuptools_scm/d' -i setup.cfg
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
-build() {
- python3 setup.py build
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/ansi2html-$pkgver-py3-none-any.whl
+ PATH="$PATH:$PWD/.testenv/bin" .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer --destdir "$pkgdir" \
+ .dist/ansi2html-$pkgver-py3-none-any.whl
}
-sha512sums="35e5fb6cee96fe41a658c005734a58b08bc05e8ad5903ad18684c316bdad351a70c534b4162416225bc2ca774d01b4ac1bb8a8dad3170d0738aa7b3daf46b3c0 ansi2html-1.6.0.tar.gz"
+sha512sums="
+1ffeffdd4f861b809c424b5b9e7d07212aaf1b5ef483a2820f128f815002628c823b5701652b0770ed182f0585052f040b55fca5db31e4690be86c49553105b3 ansi2html-1.9.1.tar.gz
+"