aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-arpeggio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-arpeggio/APKBUILD')
-rw-r--r--testing/py3-arpeggio/APKBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/testing/py3-arpeggio/APKBUILD b/testing/py3-arpeggio/APKBUILD
index dec0b74af1f..19fd9fc7a91 100644
--- a/testing/py3-arpeggio/APKBUILD
+++ b/testing/py3-arpeggio/APKBUILD
@@ -1,27 +1,19 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-arpeggio
-pkgver=1.10.2
+pkgver=2.0.2
pkgrel=0
pkgdesc="Recursive descent parser based on PEG grammars"
url="https://github.com/textX/Arpeggio"
license="MIT"
arch="noarch"
depends="python3"
-makedepends="
- py3-pytest-runner
- py3-setuptools
- "
+makedepends="py3-setuptools"
checkdepends="py3-pytest"
-source="https://github.com/textX/Arpeggio/archive/$pkgver/Arpeggio-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://github.com/textX/Arpeggio/archive/$pkgver/py3-arpeggio-$pkgver.tar.gz"
builddir="$srcdir/Arpeggio-$pkgver"
-prepare() {
- default_prepare
-
- sed -e "/wheel/d" -i setup.cfg
-}
-
build() {
python3 setup.py build
}
@@ -31,9 +23,11 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 setup.py install --skip-build --root="$pkgdir"
rm -r "$pkgdir"/usr/lib/python3.*/site-packages/arpeggio/tests
}
-sha512sums="c6a162f9ab854bac7e2bc9e5d5553c2dbcc068fcf61607149727cd4c8a7c87c63cab765b423c8ea76e09fa81ccc42157d724388a81e22864580ccf734998142a Arpeggio-1.10.2.tar.gz"
+sha512sums="
+53628b94c5181a5768be686d7c27178f77823065164dcaa421125aa3c5f2fedf2bf9e54761b92a73832dd9ae667a23eaa4ca3b00155d1acd800c00acf0f449a4 py3-arpeggio-2.0.2.tar.gz
+"