aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ask/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-ask/APKBUILD')
-rw-r--r--testing/py3-ask/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-ask/APKBUILD b/testing/py3-ask/APKBUILD
index 608a09f51f6..0cc7e1c1842 100644
--- a/testing/py3-ask/APKBUILD
+++ b/testing/py3-ask/APKBUILD
@@ -3,26 +3,30 @@
pkgname=py3-ask
_pkgname=ask
pkgver=0.0.8
-pkgrel=3
+pkgrel=8
pkgdesc="An easy input validation for Python"
options="!check" # No testsuite
url="https://github.com/chive/ask"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-replaces="py-ask" # Backwards compatibility
+replaces="py-ask" # Backwards compatibility
provides="py-ask=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="8258349066a4f57d1a5e7a136cca8330e662e135ac366b905327e9c3535ec1a949865cf20e1332d9f8a22d06c76474f86cdbd11e52bf7c002e87a3f3654ded60 ask-0.0.8.tar.gz"