aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-astral/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-astral/APKBUILD')
-rw-r--r--testing/py3-astral/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/testing/py3-astral/APKBUILD b/testing/py3-astral/APKBUILD
index 711d2402446..44c3a5ab39b 100644
--- a/testing/py3-astral/APKBUILD
+++ b/testing/py3-astral/APKBUILD
@@ -2,15 +2,16 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-astral
_pkgname=astral
-pkgver=2.2
-pkgrel=1
+pkgver=3.2
+pkgrel=3
pkgdesc="Calculations for the position of the sun and moon"
-url="https://pypi.python.org/pypi/astral"
+url="https://pypi.org/project/astral"
arch="noarch"
license="Apache-2.0"
-depends="py3-requests py3-tz python3"
-makedepends="py3-setuptools"
+depends="python3 tzdata"
+makedepends="py3-poetry-core py3-gpep517 py3-installer"
checkdepends="py3-pytest py3-freezegun"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/sffjunkie/astral/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -18,16 +19,21 @@ replaces=py-astral # Backwards compatibility
provides=py-astral=$pkgver-r$pkgrel # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
# skip the webtest since we lack an API key
- PYTHONPATH="$PWD/build/lib" py.test-3 -v -m "not webtest"
+ pytest -v -m "not webtest"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/astral-*.whl
}
-sha512sums="2b2f2c6f6f5960f747542e6410800bfab1125aa6ebe2d77d9fb4ef9e99458e808449c96855ef4d1cb8eac07f8e400e2cdbe71420391f6ee81efab31ce7693b90 astral-2.2.tar.gz"
+sha512sums="
+f463d58ecd2d251a5c9bbcc18a65d7234e596a6c4f8fdd29574049e5d6942cc3881da8e3851a052050b1e40db5db55fdd4967468b5f6bea2fa8ea597b0d65251 astral-3.2.tar.gz
+"