aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-avro/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-avro/APKBUILD')
-rw-r--r--testing/py3-avro/APKBUILD32
1 files changed, 23 insertions, 9 deletions
diff --git a/testing/py3-avro/APKBUILD b/testing/py3-avro/APKBUILD
index dac94740784..ba4e252600c 100644
--- a/testing/py3-avro/APKBUILD
+++ b/testing/py3-avro/APKBUILD
@@ -2,27 +2,41 @@
# Contributor: Gennady Feldman <gena01@gmail.com>
pkgname=py3-avro
_pkgname=avro
-pkgver=1.10.1
+pkgver=1.11.3
pkgrel=1
pkgdesc="Serialization and RPC framework"
url="https://avro.apache.org/"
arch="noarch"
license="Apache-2.0"
-depends="py3-six"
-makedepends="py3-setuptools py3-pycodestyle py3-isort"
-source="$pkgname-$pkgver.tar.gz::http://github.com/apache/$_pkgname/archive/release-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-release-$pkgver/lang/py3"
+depends="python3"
+makedepends="
+ py3-gpep517
+ py3-isort
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/apache/$_pkgname/archive/release-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-release-$pkgver/lang/py"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="ea9b68abe9d6a13aa7c661840869920ff0fe052a1e8d13fb1c78a328607d1513b031a0c8f0f0fee2cf8a4cef5980cba772c5a3e7f41f6c69d8f0489598fbcbd3 py3-avro-1.10.1.tar.gz"
+sha512sums="
+728609f562460e1115366663ede2c5d4acbdd6950c1ee3e434ffc65d28b72e3a43c3ebce93d0a8459f0c4f6c492ebb9444e2127a0385f38eb7cdf74b28f0c3ed py3-avro-1.11.3.tar.gz
+"