aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-axolotl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-axolotl/APKBUILD')
-rw-r--r--testing/py3-axolotl/APKBUILD31
1 files changed, 0 insertions, 31 deletions
diff --git a/testing/py3-axolotl/APKBUILD b/testing/py3-axolotl/APKBUILD
deleted file mode 100644
index 36510a5a045..00000000000
--- a/testing/py3-axolotl/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-pkgname=py3-axolotl
-_pkgname="python-${pkgname#py3-}"
-pkgver=0.2.3
-pkgrel=2
-pkgdesc="Python3 port of libsignal-protocol-java"
-url="https://github.com/tgalal/python-axolotl"
-arch="noarch"
-license="GPL-3.0-only"
-depends="py3-cryptography py3-protobuf py3-axolotl-curve25519"
-makedepends="py3-setuptools"
-checkdepends="py3-cparser"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tgalal/$_pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-replaces="py-axolotl" # Backwards compatibility
-provides="py-axolotl=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="1a10dc9df2f95d19b49909d4d136b5266aae19e24ac84f8b263ae7d4de18f77353c737616ac0648b600e05699a90d348f95c6c1659849986becefb4a0277fc80 py3-axolotl-0.2.3.tar.gz"