aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-api/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bottle-api/APKBUILD')
-rw-r--r--testing/py3-bottle-api/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-bottle-api/APKBUILD b/testing/py3-bottle-api/APKBUILD
index a54320d3551..da1ad3586af 100644
--- a/testing/py3-bottle-api/APKBUILD
+++ b/testing/py3-bottle-api/APKBUILD
@@ -3,27 +3,31 @@
pkgname=py3-bottle-api
_pkgname=bottle-api
pkgver=0.0.4
-pkgrel=2
+pkgrel=7
pkgdesc="Bottle JSON Web API"
options="!check" # tests not present in pypi tarballs, only github which has no tags
url="https://github.com/tomotaka/bottle-api"
arch="noarch"
license="MIT"
depends="python3 py3-bottle"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-replaces="py-bottle-api" # Backwards compat
+replaces="py-bottle-api" # Backwards compat
provides="py-bottle-api=$pkgver-r$pkgrel" # Backwards compat
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="538f0a12941a333fcae5694edba3930d449ed5464f05e760fb174481acf2bb95c413f1fa3cf67b09f7fd647c60bcbbad05a51f020d64dc41b39b25b7744308c6 bottle-api-0.0.4.tar.gz"