aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-pgsql/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bottle-pgsql/APKBUILD')
-rw-r--r--testing/py3-bottle-pgsql/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py3-bottle-pgsql/APKBUILD b/testing/py3-bottle-pgsql/APKBUILD
index fd2aaf86864..09b34294b07 100644
--- a/testing/py3-bottle-pgsql/APKBUILD
+++ b/testing/py3-bottle-pgsql/APKBUILD
@@ -3,26 +3,29 @@
pkgname=py3-bottle-pgsql
_pkgname=bottle-pgsql
pkgver=0.2
-pkgrel=1
+pkgrel=5
pkgdesc="Bottle PgSQL integration plugin"
options="!check" # No testsuite
url="https://github.com/raisoblast/bottle-pgsql"
arch="noarch"
license="MIT"
depends="python3 py3-bottle"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-bottle-pgsql" # Backwards compatibility
+replaces="py-bottle-pgsql" # Backwards compatibility
provides="py-bottle-pgsql=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="d45624d5b330be4624cac45a2a631f403679b1fa3799efd2db282ebc89cbc7f89b12c3c128a8be860d700904e420f6a2327a2bb3a18f4b0d490d423c131ef2a3 bottle-pgsql-0.2.tar.gz"