aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-redis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bottle-redis/APKBUILD')
-rw-r--r--testing/py3-bottle-redis/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-bottle-redis/APKBUILD b/testing/py3-bottle-redis/APKBUILD
index 0f50ad14d97..2ad116e8ef3 100644
--- a/testing/py3-bottle-redis/APKBUILD
+++ b/testing/py3-bottle-redis/APKBUILD
@@ -3,26 +3,30 @@
pkgname=py3-bottle-redis
_pkgname=bottle-redis
pkgver=0.2.3
-pkgrel=1
+pkgrel=6
pkgdesc="Bottle redis plugin"
options="!check" # No testsuite
url="https://github.com/bottlepy/bottle-redis"
arch="noarch"
license="MIT"
depends="python3 py3-bottle py3-redis"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-bottle-redis" # Backwards compatibility
+replaces="py-bottle-redis" # Backwards compatibility
provides="py-bottle-redis=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="7cfff9f20379be42186ed88c5de854302fb67bbb306a3ff81d41f4332e29a335e7b3ca69b89f6785d54cd9c2a0d312f3e3ac9537b1c28d70afad032ab4746008 bottle-redis-0.2.3.tar.gz"