aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-rest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bottle-rest/APKBUILD')
-rw-r--r--testing/py3-bottle-rest/APKBUILD28
1 files changed, 20 insertions, 8 deletions
diff --git a/testing/py3-bottle-rest/APKBUILD b/testing/py3-bottle-rest/APKBUILD
index da8caab8471..ea48ab96bf0 100644
--- a/testing/py3-bottle-rest/APKBUILD
+++ b/testing/py3-bottle-rest/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-bottle-rest
_pkgname=bottle-rest
-pkgver=0.5.2
+pkgver=0.6.0
pkgrel=1
pkgdesc="A decorator for REST in Bottle"
-options="!check" # Has no github tarballs with tests
-url="https://pypi.python.org/pypi/bottle-rest/"
+url="https://pypi.org/project/bottle-rest/"
arch="noarch"
license="MIT"
depends="python3 py3-bottle"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+makedepends="py3-gpep517 py3-setuptools py3-wheel py3-installer"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Bystroushaak/bottle-rest/archive/refs/tags/$pkgver.tar.gz"
replaces="py-bottle-rest" # Backwards compat
provides="py-bottle-rest=$pkgver-r$pkgrel" # Backwards compat
@@ -19,11 +20,22 @@ provides="py-bottle-rest=$pkgver-r$pkgrel" # Backwards compat
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="2071a9b6e74e9cbed6bc07d55e9f64c3752e03a5fb24640a94bf0624be27675a01e525f3830119778d29b76b57fda1a7cb34895adc1332b038d0840ce27d11cb bottle-rest-0.5.2.tar.gz"
+sha512sums="
+abc34f287866188e84d3636df5d279061bbe9bc2dbc56bf1a6bafb39b255b5b04ae03fc0a2357e3d9a63ef100dfd3e630a408f84c05f8cbfe685e68a87a2ea93 py3-bottle-rest-0.6.0.tar.gz
+"