aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-sqlite/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bottle-sqlite/APKBUILD')
-rw-r--r--testing/py3-bottle-sqlite/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-bottle-sqlite/APKBUILD b/testing/py3-bottle-sqlite/APKBUILD
new file mode 100644
index 00000000000..608314f0492
--- /dev/null
+++ b/testing/py3-bottle-sqlite/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-bottle-sqlite
+_pkgname=bottle-sqlite
+pkgver=0.2.0
+pkgrel=7
+pkgdesc="Bottle sqlite plugin"
+options="!check" # No testsuite
+url="https://pypi.org/project/bottle-sqlite"
+arch="noarch"
+license="MIT"
+depends="python3 py3-bottle"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-bottle-sqlite" # Backwards compatibility
+provides="py-bottle-sqlite=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+package() {
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="5110adc5b1e7196aec28f96495db805bb16cace3ec2b4e4ccd40ad10f5cf8bea811568c3a8c876507ee76d146da0b576c7d0e7d34ca8d7f28ee64d858cedf3e4 bottle-sqlite-0.2.0.tar.gz"