aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-werkzeug/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bottle-werkzeug/APKBUILD')
-rw-r--r--testing/py3-bottle-werkzeug/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-bottle-werkzeug/APKBUILD b/testing/py3-bottle-werkzeug/APKBUILD
index c1f06734348..b15200c3e5e 100644
--- a/testing/py3-bottle-werkzeug/APKBUILD
+++ b/testing/py3-bottle-werkzeug/APKBUILD
@@ -3,26 +3,30 @@
pkgname=py3-bottle-werkzeug
_pkgname=bottle-werkzeug
pkgver=0.1.1
-pkgrel=3
+pkgrel=9
pkgdesc="Bottle werkzeug plugin"
-url="https://pypi.python.org/pypi/bottle-werkzeug"
+url="https://pypi.org/project/bottle-werkzeug"
arch="noarch"
license="MIT"
depends="python3 py3-bottle py3-werkzeug"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
options="!check"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-replaces="py-bottle-werkzeug" # Backwards compatibility
+replaces="py-bottle-werkzeug" # Backwards compatibility
provides="py-bottle-werkzeug=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="13fce3be73caa42c8cbdf437799c1fdb32a6e1ea513055ce9cd53788cea318a6d990b0975b39bcbad3b6fb2994d17d29651603687f59604e81508e61b3b0319a bottle-werkzeug-0.1.1.tar.gz"