aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bson/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bson/APKBUILD')
-rw-r--r--testing/py3-bson/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/testing/py3-bson/APKBUILD b/testing/py3-bson/APKBUILD
index a534458f3b6..d57dc3c4169 100644
--- a/testing/py3-bson/APKBUILD
+++ b/testing/py3-bson/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=py3-bson
_pkgname=bson
-pkgver=0.5.9
-pkgrel=0
+pkgver=0.5.10
+pkgrel=5
pkgdesc="Independent BSON codec for Python that doesn’t depend on MongoDB"
options="!check" # No testsuite
url="https://github.com/py-bson/bson"
@@ -11,6 +11,7 @@ arch="noarch"
license="BSD-3-Clause"
depends="py3-dateutil py3-six"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/${_pkgname/-/_}-$pkgver
@@ -19,11 +20,11 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
check() {
python3 setup.py test
}
-sha512sums="7536db67ab5d0f9fe502cd4951dbdf667253f83eeaabeaa634c4168d57545499d833c57daa5b1012dfc5c541faf94454a379b690bada0a9e5f978f388b257021 bson-0.5.9.tar.gz"
+sha512sums="649c34aecbcf0e57bd2363bf05d4a7ce58d8dd5b7c25608136fe0155297f800e867df1c4f4785fb4f7db88aa4d79f2d23c401eedbec66056a12dd9d451f2a96b bson-0.5.10.tar.gz"