aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bson/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bson/APKBUILD')
-rw-r--r--testing/py3-bson/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-bson/APKBUILD b/testing/py3-bson/APKBUILD
index d18d11c421c..d57dc3c4169 100644
--- a/testing/py3-bson/APKBUILD
+++ b/testing/py3-bson/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-bson
_pkgname=bson
pkgver=0.5.10
-pkgrel=1
+pkgrel=5
pkgdesc="Independent BSON codec for Python that doesn’t depend on MongoDB"
options="!check" # No testsuite
url="https://github.com/py-bson/bson"
@@ -11,6 +11,7 @@ arch="noarch"
license="BSD-3-Clause"
depends="py3-dateutil py3-six"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/${_pkgname/-/_}-$pkgver
@@ -19,7 +20,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
check() {