aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-build/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-build/APKBUILD')
-rw-r--r--testing/py3-build/APKBUILD29
1 files changed, 0 insertions, 29 deletions
diff --git a/testing/py3-build/APKBUILD b/testing/py3-build/APKBUILD
deleted file mode 100644
index af64e1d64f3..00000000000
--- a/testing/py3-build/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py3-build
-_pkgname=build
-pkgver=0.1.0
-pkgrel=1
-pkgdesc="Correct PEP517 package builder"
-url="https://github.com/pypa/build"
-arch="noarch"
-license="MIT"
-depends="python3"
-# Test suite is not shipped at the moment
-options="!check"
-makedepends="py3-setuptools py3-wheel"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-replaces=py-build # Backwards compatibility
-provides=py-build=$pkgver-r$pkgrel # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="23d40fa9d037ff4ba640ece9c38d4a47d28a7640df71f6647b7018a7d8fb63b00924cb3e412d04a84130de52e0ed7cfa8bb118f9c87ed15c6b0958c6cc0bfca9 build-0.1.0.tar.gz"