aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-businesstime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-businesstime/APKBUILD')
-rw-r--r--testing/py3-businesstime/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/testing/py3-businesstime/APKBUILD b/testing/py3-businesstime/APKBUILD
index d1d10914e4b..b8c5e08379f 100644
--- a/testing/py3-businesstime/APKBUILD
+++ b/testing/py3-businesstime/APKBUILD
@@ -3,26 +3,28 @@
pkgname=py3-businesstime
_pkgname=businesstime
pkgver=0.3.0
-pkgrel=4
+pkgrel=8
pkgdesc="Python utility for calculating business time between two datetimes"
url="https://github.com/seatgeek/businesstime"
arch="noarch"
license="BSD-2-Clause"
-replaces="py-businesstime" # for backwards compatibility
+replaces="py-businesstime" # for backwards compatibility
provides="py-businesstime=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="python3-dev py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="20e44a0057c66c15cf79452f2a602c8e1719f866c608bfffe25ec14fb5c3ec06fcd6f7ac93e2328ee38ea862464c128d8b3a66a544f13fd0f989fc3d6a3d10a7 businesstime-0.3.0.tar.gz"