aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-businesstime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-businesstime/APKBUILD')
-rw-r--r--testing/py3-businesstime/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/py3-businesstime/APKBUILD b/testing/py3-businesstime/APKBUILD
new file mode 100644
index 00000000000..4830253fc62
--- /dev/null
+++ b/testing/py3-businesstime/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-businesstime
+_pkgname=businesstime
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="A Python utility for calculating business time between two datetimes"
+url="https://github.com/seatgeek/businesstime"
+arch="noarch"
+license="BSD"
+provides="py-businesstime" # for backwards compatibility
+replaces="py-businesstime=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+depends_dev=""
+makedepends="python3-dev py3-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6bba38b1f60d4a4d6c49ef9a0ef6a3ec businesstime-0.1.4.tar.gz"
+sha256sums="65514b0833c1234f82f7386956fe1b558fa70bdc5c05605dbdb740695d99c2a6 businesstime-0.1.4.tar.gz"
+sha512sums="7ef7b6053855708c8aac48a8f6af34f55e2a389a6a7b954c3c6e2f542ced5ef22c73392c483b2fe8de387c0c8b57eea6edb0ce714ba66755b10d5ea3eb1add34 businesstime-0.1.4.tar.gz"