aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cachy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-cachy/APKBUILD')
-rw-r--r--testing/py3-cachy/APKBUILD43
1 files changed, 0 insertions, 43 deletions
diff --git a/testing/py3-cachy/APKBUILD b/testing/py3-cachy/APKBUILD
deleted file mode 100644
index 897f7658f65..00000000000
--- a/testing/py3-cachy/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Duncan Bellamy <dunk@denkimushi.com>
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
-pkgname=py3-cachy
-_realname=cachy
-pkgver=0.3.0
-pkgrel=3
-pkgdesc="Simple yet effective caching library"
-url="https://github.com/sdispater/cachy"
-arch="noarch"
-license="MIT"
-depends="python3"
-makedepends="pyproject2setuppy"
-checkdepends="py3-pytest py3-flexmock py3-fakeredis"
-source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
-
-prepare() {
- default_prepare
- cat <<- __EOF__ >> pyproject.toml
-
- [build-system]
- build-backend = "poetry.core.masonry.api"
- __EOF__
-}
-
-build() {
- python3 -m pyproject2setuppy.main build
-}
-
-check() {
- PYTHONPATH="$PWD/build/lib" py.test-3 -v \
- --deselect tests/stores/test_memcached_store.py::RedisStoreTestCase
-}
-
-package() {
- python3 -m pyproject2setuppy.main install --prefix=/usr --root="$pkgdir"
- rm -rf "$pkgdir"/usr/lib/python3*/site-packages/tests
-}
-
-sha512sums="
-0b69bd45ce81fc57710b44011965b8c4a313808f7c464a409b839d9206158f91b1e39a760d08d62bb5eb15e455ba9b89683f0eb42d2bfcc2e99b0b8f267e3ead cachy-0.3.0.tar.gz
-"