aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-case/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-case/APKBUILD')
-rw-r--r--testing/py3-case/APKBUILD30
1 files changed, 0 insertions, 30 deletions
diff --git a/testing/py3-case/APKBUILD b/testing/py3-case/APKBUILD
deleted file mode 100644
index e77e18e9ed6..00000000000
--- a/testing/py3-case/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py3-case
-_pyname=case
-pkgver=1.5.3
-pkgrel=2
-pkgdesc="Python unittest utilities"
-url="https://github.com/celery/case/"
-arch="noarch"
-license="BSD-3-Clause"
-makedepends="py3-setuptools"
-checkdepends="py3-coverage py3-mock py3-nose"
-_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
-builddir="$srcdir/$_pyname-$pkgver"
-
-replaces="py-case" # Backwards compatibility
-provides="py-case=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-sha512sums="ae98a571c282f80c685c42ab1dc578847fe88cf8cd07faff505a8df8e3282a602908a8780ab88b36851e3ee6f3c178405e5c50776fd0f49fcc990087575f2958 case-1.5.3.tar.gz"