aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cchardet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-cchardet/APKBUILD')
-rw-r--r--testing/py3-cchardet/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/py3-cchardet/APKBUILD b/testing/py3-cchardet/APKBUILD
index 941b96fa899..5f16986809c 100644
--- a/testing/py3-cchardet/APKBUILD
+++ b/testing/py3-cchardet/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: MichaƂ Adamski <michal@ert.pl>
pkgname=py3-cchardet
pkgver=2.1.7
-pkgrel=0
+pkgrel=3
pkgdesc="High speed universal character encoding detector"
url="https://github.com/PyYoshi/cChardet"
arch="all"
license="MPL-1.1"
-makedepends="py3-setuptools python3-dev"
+makedepends="cython py3-setuptools python3-dev"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/c/cchardet/cchardet-$pkgver.tar.gz"
builddir="$srcdir/cchardet-$pkgver"
@@ -19,7 +20,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
43e663e30ec079b2a954862de5e8136a2e40f69e300d65eb4ce9d7ffa5d8c496dc7c0937b3306b4096cfad12a1d0617628f8f0115534ab6faf9eb39d2b3935a2 cchardet-2.1.7.tar.gz