aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cherrypy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-cherrypy/APKBUILD')
-rw-r--r--testing/py3-cherrypy/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/py3-cherrypy/APKBUILD b/testing/py3-cherrypy/APKBUILD
deleted file mode 100644
index 34cc2e49160..00000000000
--- a/testing/py3-cherrypy/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py3-cherrypy
-pkgver=18.6.0
-pkgrel=1
-pkgdesc="A pythonic, object-oriented web development framework"
-url="http://www.cherrypy.org"
-arch="noarch"
-license="BSD-3-Clause"
-depends="python3 py3-six"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/C/CherryPy/CherryPy-$pkgver.tar.gz"
-builddir="$srcdir"/CherryPy-$pkgver
-replaces="py-cherrypy" # Backwards compatibility
-provides="py-cherrypy=$pkgver-r$pkgrel" # Backwards compatibility
-
-prepare() {
- default_prepare
-
- sed -e "s/use_scm_version=True/version='$pkgver'/" \
- -e '/setuptools_scm/d' \
- -i setup.py
-}
-
-build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- rm -rf "$pkgdir"/usr/lib/python3*/site-packages/cherrypy/test
-}
-
-sha512sums="cd33303fa9b9704ef427553091a6a6c2bbfea20e7d81acd2bcdc2855f8a36a084a0781bb19f3a084b24f0664bd7b318a667c8c79b5073381901acce4602de9d7 CherryPy-18.6.0.tar.gz"