aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cherrypy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-cherrypy/APKBUILD')
-rw-r--r--testing/py3-cherrypy/APKBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/testing/py3-cherrypy/APKBUILD b/testing/py3-cherrypy/APKBUILD
deleted file mode 100644
index 3d1ade3ff13..00000000000
--- a/testing/py3-cherrypy/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributer: Fabian Affolter <fabian@affolter-engineering.ch>
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Contributor: Jiri Kastner <cz172638@gmail.com>
-# Contributor: Duncan Bellamy <dunk@denkimushi.com>
-# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
-pkgname=py3-cherrypy
-pkgver=18.6.1
-pkgrel=1
-pkgdesc="A pythonic, object-oriented web development framework"
-url="http://www.cherrypy.org"
-arch="noarch"
-license="BSD-3-Clause"
-depends="py3-cheroot py3-jaraco.collections py3-portend py3-zc.lockfile"
-makedepends="py3-setuptools"
-checkdepends="py3-cheroot-tests py3-path py3-pytest py3-pytest-cov py3-requests-toolbelt py3-tz"
-source="https://files.pythonhosted.org/packages/source/C/CherryPy/CherryPy-$pkgver.tar.gz
- tests.patch
- test_timeout.patch
- gziptest.patch
- setuptools_scm.patch
- "
-builddir="$srcdir"/CherryPy-$pkgver
-replaces="py-cherrypy" # Backwards compatibility
-provides="py-cherrypy=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 -m pytest -W ignore::DeprecationWarning -W ignore:"unclosed ":ResourceWarning \
- --deselect=cherrypy/test/test_session.py::MemcachedSessionTest
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- rm -rf "$pkgdir"/usr/lib/python3*/site-packages/cherrypy/test
-}
-
-sha512sums="
-186a0992a443e1ffc1a2924b3351dcb0e6cc6c88b39ac32330d6365fe1b0a35c2008a3a18e1a57f61ffd1901ea6134333bb6288024d8ffbb1fd8e8dcd3145007 CherryPy-18.6.1.tar.gz
-64d5e51822fca9045f76894a4e5322b80b2c7826eea21fc97e81bffe419a5f940481b807dad70eee53e4a31bc3598ed10252e7ae97c1d7dcb7ba4085ab3298d6 tests.patch
-0f0d73e9471d56eab74265ae857d923d9605ea54cc7b8c110a8e7639b325bbab8a4c6c05b777514cb875d0ae4d8c50d34ed0bf4445782cdf30865a140a7fa68e test_timeout.patch
-cc0384514a3cef41cbfcc441ba66a26feaf71cbd7ab092c8281782dfdfdccaa20cf5facf414e97cb88dd8e7c377067c8b6afdef4f71f22dee4c60db6a02c483b gziptest.patch
-b06119caa41c70a50f7dca109b581cb5a8043630c5ba7299f699e9ac6bad9bde8cca08b3bc946a0ae65ea425998c9c9c24db3c743bcb17d2d46cbafefc04b64c setuptools_scm.patch
-"