aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cli_helpers/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-cli_helpers/APKBUILD')
-rw-r--r--testing/py3-cli_helpers/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/py3-cli_helpers/APKBUILD b/testing/py3-cli_helpers/APKBUILD
deleted file mode 100644
index 74e7c17c72c..00000000000
--- a/testing/py3-cli_helpers/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Thomas Boerger <thomas@webhippie.de>
-# Maintainer: Thomas Boerger <thomas@webhippie.de>
-pkgname=py3-cli_helpers
-_pkgname=cli_helpers
-pkgver=1.2.1
-pkgrel=3
-pkgdesc="A helper library for command-line interfaces"
-url="https://pypi.python.org/pypi/cli-helpers"
-arch="noarch"
-license="BSD-3-Clause"
-depends="py3-terminaltables py3-tabulate py3-configobj"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-wcwidth py3-mock"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-replaces="py-cli_helpers" # Backwards compatibility
-provides="py-cli_helpers=$pkgver-r$pkgrel" # Backwards compatiblity
-
-check() {
- py.test-3
-}
-
-build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="46f83382800da7e6ba9116df5cd77bf012e14af821a842e73a7f0ddae64e032dd2d00c124b0f0ed18a07226058dbc41185e99ccd7616e971116a57a22ceace51 py3-cli_helpers-1.2.1.tar.gz"