aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-codespell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-codespell/APKBUILD')
-rw-r--r--testing/py3-codespell/APKBUILD29
1 files changed, 0 insertions, 29 deletions
diff --git a/testing/py3-codespell/APKBUILD b/testing/py3-codespell/APKBUILD
deleted file mode 100644
index 174a4d08a7a..00000000000
--- a/testing/py3-codespell/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-pkgname=py3-codespell
-_pkgname=${pkgname#py3-}
-pkgver=2.0.0
-pkgrel=1
-pkgdesc="Fix common misspellings in text files, primarily source code"
-url="https://github.com/codespell-project/codespell/"
-arch="noarch"
-license="GPL-2.0-only"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-depends="py3-chardet"
-source="$pkgname-$pkgver.tar.gz::https://github.com/codespell-project/codespell/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-check() {
- python3 setup.py test
-}
-
-build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="ca9fc6661be77eddca1a5b3b15a72abc0506c61826487e8f50c546b923c065c6cbfb2b4c4bbace136d811e2e8cf2fe00106efcc3eb8805181ca6bd04fd4bf638 py3-codespell-2.0.0.tar.gz"