aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-confluent-kafka/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-confluent-kafka/APKBUILD')
-rw-r--r--testing/py3-confluent-kafka/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/testing/py3-confluent-kafka/APKBUILD b/testing/py3-confluent-kafka/APKBUILD
index fcd6801a9f3..8250513ed02 100644
--- a/testing/py3-confluent-kafka/APKBUILD
+++ b/testing/py3-confluent-kafka/APKBUILD
@@ -2,16 +2,17 @@
# Contributor: Gennady Feldman <gena01@gmail.com>
pkgname=py3-confluent-kafka
_pkgname=confluent-kafka-python
-pkgver=1.7.0
-pkgrel=0
+pkgver=1.8.2
+pkgrel=4
pkgdesc="Confluent's Apache Kafka Python clien"
url="https://github.com/confluentinc/confluent-kafka-python"
-arch="all !x86 !mips !mips64" # Restricted by py3-fastavro
+arch="all !x86" # Restricted by py3-fastavro
license="Apache-2.0"
-depends="py3-six py3-avro py3-fastavro py3-requests"
+depends="py3-avro py3-fastavro py3-jsonschema py3-protobuf py3-requests"
makedepends="py3-setuptools python3-dev librdkafka-dev>=1.0.1"
checkdepends="py3-pytest py3-trivup"
options="!check" # missing deps
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/confluentinc/confluent-kafka-python/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -24,9 +25,10 @@ check() {
PYTHONPATH=. python3 -m pytest -v tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
+ rm "$pkgdir"/usr/LICENSE.txt
}
sha512sums="
-06bd27dfda151fa860f59d740c64e9d93e7a53c95e9b57eb0730cc0058471dbc6b1ecafd769b97c13ef66c0c34634686108ccbba18882f6613052e4e5e409ef4 py3-confluent-kafka-1.7.0.tar.gz
+6db66371b7cac822aafeaa4acb491556d9a866f8502d76e2acfe52d18b282caab338cd3f51f84845eab2ec5b2c44ed80426a7ad8afd0314a8a5ddc1a9299d693 py3-confluent-kafka-1.8.2.tar.gz
"