aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-coreapi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-coreapi/APKBUILD')
-rw-r--r--testing/py3-coreapi/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/py3-coreapi/APKBUILD b/testing/py3-coreapi/APKBUILD
index cfd130c32e5..d1afe2e66e8 100644
--- a/testing/py3-coreapi/APKBUILD
+++ b/testing/py3-coreapi/APKBUILD
@@ -3,14 +3,14 @@
pkgname=py3-coreapi
_pkgname=python-client
pkgver=2.3.3
-pkgrel=3
+pkgrel=8
pkgdesc="client library for Core API"
url="https://github.com/core-api/python-client"
arch="noarch"
license="BSD-3-Clause"
-depends="py3-coreschema py3-requests py3-itypes py3-uritemplate"
-makedepends="py3-setuptools"
+depends="py3-coreschema py3-requests py3-itypes py3-uritemplate py3-setuptools"
checkdepends="py3-pytest py3-coverage"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-client/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -23,7 +23,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="aeae3ace84c0ce61552236b83db28e47492f5ac17a0e216e1a8eeddaf67270b94127f7a40f8a37cc5051abe097555adfd690a7e6c8801524ca77c916bd451ab8 py3-coreapi-2.3.3.tar.gz"