aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-crc16
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-crc16')
-rw-r--r--testing/py3-crc16/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-crc16/APKBUILD b/testing/py3-crc16/APKBUILD
index 610bb243d20..e7d65953671 100644
--- a/testing/py3-crc16/APKBUILD
+++ b/testing/py3-crc16/APKBUILD
@@ -3,24 +3,28 @@
pkgname=py3-crc16
_pkgname=crc16
pkgver=0.1.1
-pkgrel=6
+pkgrel=10
pkgdesc="Python library for calculating CRC16"
url="https://github.com/gtrafimenkov/pycrc16"
arch="all"
license="LGPL-3.0-or-later"
-replaces="py-crc16" # for backwards compatibility
+replaces="py-crc16" # for backwards compatibility
provides="py-crc16=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="python3-dev py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="45d5e8e13b1ac5f885b40516872a9233514f09aa8990915904b214eec2ef6084016f8f0c15bb411aaa1ffc32e8207020916f723e48eee726a7e6989901c9e65d crc16-0.1.1.tar.gz"