aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cryptography-latest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-cryptography-latest/APKBUILD')
-rw-r--r--testing/py3-cryptography-latest/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/py3-cryptography-latest/APKBUILD b/testing/py3-cryptography-latest/APKBUILD
new file mode 100644
index 00000000000..59c88c83199
--- /dev/null
+++ b/testing/py3-cryptography-latest/APKBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Mogens Jensen <mogens-jensen@protonmail.com>
+
+pkgname=py3-cryptography-latest
+_pyname=cryptography
+pkgver=37.0.2
+pkgrel=0
+pkgdesc="Cryptographic recipes and primitives for Python - latest version"
+url="https://cryptography.io/"
+arch="all !riscv64 !s390x"
+license="Apache-2.0 OR BSD-3-Clause"
+depends="python3
+ py3-cffi
+ py3-idna
+ py3-six
+ "
+makedepends="cargo
+ libffi-dev
+ openssl-dev
+ python3-dev
+ py3-setuptools
+ py3-setuptools-rust
+ py3-typing-extensions
+ "
+checkdepends="py3-hypothesis
+ py3-iso8601
+ py3-pretend
+ py3-pytest
+ py3-pytest-benchmark
+ py3-pytest-subtests
+ py3-tz
+ "
+source="https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-$pkgver.tar.gz
+ https://files.pythonhosted.org/packages/source/c/cryptography_vectors/cryptography_vectors-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+
+ # prepare cryptography vectors for testing
+ cd "$srcdir/cryptography_vectors-$pkgver"
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$(echo $PWD/build/lib.linux-*):$srcdir/cryptography_vectors-$pkgver/build/lib" pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+}
+
+sha512sums="
+28d8b52ca457dec0c854ffb798c9ecb4316c3f161ece5c304c7a5e0cdc86e8b567f1cea82f96f23b01af611e04f48fa310c0e78b3175f4b06e9175acc6a2de45 cryptography-37.0.2.tar.gz
+320a4c13f076d6d7bef0437b8b57a76496c51d0266c9958aaeadf73e9d07510e1219f3fa08aee1b30cb6122daf4c0b85538c5be95f1dbd450bacb8cbe464892b cryptography_vectors-37.0.2.tar.gz
+"