aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cssutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-cssutils/APKBUILD')
-rw-r--r--testing/py3-cssutils/APKBUILD31
1 files changed, 23 insertions, 8 deletions
diff --git a/testing/py3-cssutils/APKBUILD b/testing/py3-cssutils/APKBUILD
index 5fd88b2baa9..3f8e0fe3dd7 100644
--- a/testing/py3-cssutils/APKBUILD
+++ b/testing/py3-cssutils/APKBUILD
@@ -2,23 +2,38 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-cssutils
_pkgname=cssutils
-pkgver=1.0.2
-pkgrel=4
+pkgver=2.9.0
+pkgrel=0
pkgdesc="CSS Cascading Style Sheets library for Python"
url="http://cthedot.de/cssutils/"
arch="noarch"
license="LGPL-3.0-or-later"
-depends="python3"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+makedepends="py3-gpep517 py3-setuptools py3-setuptools_scm py3-wheel"
+checkdepends="py3-pytest py3-jaraco.test"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/c/cssutils/cssutils-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest cssutils/tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/cssutils*.whl
+
+ rm -r "$pkgdir"/usr/lib/python3*/site-packages/cssutils/tests
}
-sha512sums="4988893875a03923d3127e334654799e5c2ebcdc0a7f5b3fb5c9ab27d1b331caa5bf197161312a298531e0757843aa3259ceba5fa19947353eea24a5da53ceda cssutils-1.0.2.tar.gz"
+sha512sums="
+d13d53b3e4f133afb5b72faba1e41a95cf2b146efb075dd3b328fc424eccd371194e1e14fd9e607b207b5c7d473e64f1e4c63975173d8491fa8036a16dc94d38 cssutils-2.9.0.tar.gz
+"